Status

Some domains may be miscategorized Monday 1st May 2023 20:10:00


May 2 2023 03:10 UTC: We are investigating the miscategorization of some URLs, particularly in EMEA/APAC regions. We are working with our partners to implement a fix

Update 03:25 UTC: We are beginning to see initial signs of recovery as we work with our partner to mitigate the issue. We will continue to monitor and ensure full recovery.

Update 03:45 UTC: We are continuing to see recovery of the impacted URL categorizations.

Update 04:00 UTC: We have mitigated the URL categorization issues with our partner.