Status

service disruption impacting proxy services in all regions Thursday 27th July 2023 00:36:00


07:25 UTC: We are currently experiencing a service disruption impacting proxy services in all regions When customer access to specific web sites, it may be experiencing issue with 503 Service Unavailable, "Failed to establish a secure connection" The Menlo Security Operations team is working to identify the root cause and resolve as quickly as possible.

Update 10:45

Users browsing via proxy (in either isolation or allow mode) may experience a 503 Service Unavailable "Failed to establish a secure connection" error, when connecting to specific websites configured with a weak key or certificate signature. These websites continue to load normally when accessed via prepend. The Menlo Security Operations team is working to mitigate impact, until a more permanent solution can be put in place.

Update: 2023-07-28 7:00 UTC: The mitigation is now in place. The issue has now been resolved