Status

Investigating performance issues in us-east-1 Saturday 29th April 2023 13:35:36


We received reports from customers of potential performance issues in us-east-1 and we are actively investigating

Update 2023-04-30 22:20 UTC: we applied configuration updates to our egress nodes in all regions and we also refreshed our isolation containers in the US to remove any unhealthy nodes. Metrics indicate the performance issues are resolved and service is back to operational.

Update 2023-04-30 08:55 UTC: we identified a set of configuration that weren't correctly applied in a few of our egress clusters. We are actively working to correctly apply the configuration, prioritizing the clusters that are seeing timeouts.

Update 23:32 UTC: We did identify a change that corresponds with the initial timeline of events. We reverted the change but this did not resolve the issue. We've continuing to investigate the issue.

Update 22:31:00 UTC: We've determined isolation in us-west-1 and us-east-1 are getting page timeouts. Investigation is still ongoing.