We are currently experiencing a service disruption impacting the Menlo Security Web Isolation.
A small set of users in the Virginia region may be experiencing stuck web isolation sessions.
The Menlo Security Operations team is working to identify the root cause and resolve as quickly as possible.
We will send an additional update in 20 minutes.
Update 1611 UTC The stuck browsing issue appears to be specific to two customers only at this time. Engineerng and Operations are continuing the investigation.
Update 1640 UTC Menlo Engineering and Operations are investigating the browsing issue with affected customer.
Update 1710 UTC Menlo Engineering and Operations are continuing the investigation with the affected customer.
Update 1745 UTC Menlo Engineering and Operations are working with the customer to diagnose possible network issues connecting to Menlo.
Update 1810 UTC Menlo Engineering and Operations are working with the customer to diagnose the issue via Chrome devtools.
Update 18:45 UTC Investigation with the customer is showing that a web isolation network communications path is getting blocked.
Update 19:40 UTC Investigation continues with the diagnosing the network path with the relevant network teams at the customer site.
Update 20:41 UTC The investigation at the customer site has been escalated to the core networking team. Investigation continues to see where the isolation traffic is getting dropped.
Update 22:00 UTC A workaround was put in place to restore web isolation browsing for the two affected customers. Investigations with the networking teams are still ongoing.
Update 22:20 UTC Network investigations are still ongoing with the customer. The next update will be provided when the investigation provides new findings.
Update 0000 UTC, 2021-08-07 This outage has been determined to be not caused by Menlo Security, but a network block on the customer network.