Status

Service Disruption Wednesday 15th December 2021 08:00:00


Update 17:00 UTC: Menlo Security operations has confirmed that the network outage has fully recovered and all systems are operational.

Update 16:20 UTC: Our hosting provider has confirmed the network issue impacting California and Oregon regions has been resolved, and we are seeing traffic recovery with Web Isolation in those regions. Menlo Security operations will continue to monitor for any further changes.

We are currently experiencing a service disruption impacting Menlo Security Web Isolation.

Users in the California and Oregon may be experiencing connectivity issues or degraded performance

The Menlo Security Operations team is working to identify the root cause and resolve as quickly as possible.

We will send an additional update in 30 minutes.