Update 17:27 UTC We are currently experiencing a service disruption impacting the Menlo Security Isolation.
Users browsing via Bounce cluster 57 (Taiwan) may experience slow browsing and/or timeouts. The Menlo Security Operations team has identified the cause and are working with our service provider in this region to resolve the issue.
Update 12:20 UTC TechOps Engineers have confirmed nodes in the bounce cluster 57 (Taiwan) have now recovered.
10:46 UTC We are currently experiencing a service disruption impacting the Menlo Security Isolation.
Users browsing via Bounce cluster 57 (Taiwan) may experience slow browsing and/or timeouts.
The Menlo Security Operations team has identified the cause and are working with our service provider in this region to resolve the issue.
1935 UTC Web browsing via our Taiwan egress cluster is back to normal. Menlo Security Operations will continue to monitor for the next few hours.
0412 UTC 2022-10-14 Menlo Security Operations has completed an extended observation period and and not seen a reoccurrence of slow web browsing or timeout through the Taiwan egress cluster. Incident is resolved.